Link to online Help does not work

Incident Report for TrustSource

Resolved

We deployed an update fixing the access link. Thus, you may access the online help as usual through the question mark icon on the upper right hand corner. We appologise for the inconvenience.
Posted Aug 12, 2025 - 21:12 CEST

Monitoring

We recognised an issue in invoking the online help from inside the application. Instead of starting the dialogue, an endless loading icon appears. This is caused by an update of the security headers requirement and will be fixed shortly.
To make use of the help meanwhile, please navigate to https://support.trustspurce.io and use it from there.
Thank you for your support. We will notify you as soon as the fix has been deployed.
Posted Aug 11, 2025 - 16:43 CEST