TrustSource Component Crawler for nuget failing
Incident Report for TrustSource
Resolved
Nuget crawler is back to normal operations.
Since the failing prevented any updates, the failed component has been requested again each time the crawler started operating. Removing the component did not do the trick, since there were several Nuget documentations containing these illegal characters. So we needed to provide an updated crawler.
Posted May 06, 2022 - 22:47 CEST
Monitoring
A workaround for a short term compensation has been provided, which should overcome the limitations temporarily. We will be monitoring the outcomes and continue to work on a final resolution.
Posted Apr 22, 2022 - 00:39 CEST
Identified
We recognized that our nuget componet crawler is failing while parsing nuget data due to an unhandled illegal character exception. We handed this to our dev team, which will provide an updated version.
This will impact quality and accuracy of data concerning latest nuget component updates as long as the fix has not been provided.
We will update as soon as this has been resolved.
Posted Apr 21, 2022 - 23:33 CEST
This incident affected: TrustSource Services (Component Crawlers).