Login issues
Incident Report for TrustSource
Resolved
We can confirm this to be a local issue only. It is limited to a single company. So there is no overall impact.
Posted Mar 25, 2019 - 14:27 CET
Investigating
We are currently experiencing login issues in several regions. We are investigating the problem.
Posted Mar 25, 2019 - 11:41 CET
This incident affected: TrustSource Services (Core Service).