DeepScan Service blocked for registered users
Incident Report for TrustSource
Resolved
Closing this as monitoring did not encounter any errors anymore. Please notify support in case you will receive a "forbidden" error when executing a DeepScan Scan from inside the app or while using a valid API Key. They can investigate usage plans and adjust according to your license. Thank you for your patience
Posted Sep 07, 2023 - 22:41 CEST
Monitoring
Meanwhile all updates seem to have completed. We will keep this open and monitor behaviour.
Posted Sep 07, 2023 - 19:01 CEST
Identified
During an update of DeepScan Service and API we ran into a situation where DeepScan is not available to our registered users anymore. Due to some limitations in the processing of usage plan updates, this might impact some users until tomorrow (Sept. 8th). We are aware of this and we are working to resolve it as fast as possible.
For those who want to assess public code repos, you may use the public service at https://deepscan.trustsource.io instead. This is not impacted. Please expect this to be resolved either throughout the day or - depending on your companies position in the list - by tomorrow morning.
Posted Sep 07, 2023 - 10:45 CEST
This incident affected: TrustSource Services (DeepScan Service, DeepScan API).