UI shows 504
Incident Report for TrustSource
Postmortem

What has happened?

It may happen that an analysis of modules containing a very large dependency tree (>2000 elements) causes the session to fail during an analysis. This will impact only the particular session, not the complete instance. Due to sticky sessions the user in this case may experience a 504.

How to resolve?

To resolve, you must get rid of your session. You might try to get a logout managed. It might be difficult as you will be redirected to the broken session. So either try using a private browser window or remove your TrustSource cookie and login again.

What to expect?

We have learned from this event and are about to develop several solutions to prevent further appearances. However, the amount of incidents seems to be rare (as might be the case of having so many dependencies in one component). Probably you should think of using such components as “infrastructure components” instead of module dependencies. see our knowledge base for more information on infrastructure components.

Posted Feb 27, 2019 - 17:36 CET

Resolved
We surveyed the system for several hours, but the issue did not occur anymore. However some fixes are under development to prevent further appearances. As long as this patch is not deployed, the incident may happen again.
The issue affects only a single session. Not the overall system. To resolve it, please log out and log in again. It is important, to create a new session, as the session-object will be lost.
Posted Feb 27, 2019 - 17:09 CET
Monitoring
In some cases, it may happen that you will experience a 504 error message. The cause of this incident has been identified but is not yet completely resolved. The overall system integrity is not impacted, it is a session specific
To overcome the situation, please go back and log out. You will be able to login again and continue working. We apologize for any inconvenience and our team is about to resolve the issue soon.
Posted Feb 27, 2019 - 10:24 CET
This incident affected: TrustSource Services (Core Service).